Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please Help: Root-NFS: No NFS Server

> > The documentation says that in 2.2 kernels the default is /tftpboot/<domain>, so my
> > tftpboot contains the root file system under the dir /tftpboot/
> >
> > I have even tried the mknbi -x -k zImage -o vmlinuz -d /tftpboot/ -i
> >  -> same result No NFS server available.
> >
>   What doesn't your boottab line look like, and why don't you specify the
> nfs root there?

I'm using DHCP, and dhcpd.conf looks like this:

default-lease-time 600;
max-lease-time 7200;
option subnet-mask;
option broadcast-address;
option routers;
option domain-name-servers,;
option netbios-name-servers;
option domain-name "";

subnet netmask {
        host carolina1 {
                hardware ethernet 00:E0:29:58:98:86;
                filename "/tftpboot/vmlinuz";

Can I specify nfsroot using DHCP?

Should I switch to bootp instead?

thx - Eric

This Mail was sent to netboot mailing list by:
Eric Dahnke <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to