Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please Help: Root-NFS: No NFS Server

On Thu, Apr 06, 2000 at 11:55:31PM -0500, Eric Dahnke wrote:
> Hello List,
> Background details: S=RH 6.1 - kernel 2.2-13smp. DC's kernel compiled on similar
> machine. S(NFS)=knfsd-1.4.7-7, knfsd-clients-1.4.7-7. DC nic = smc 1211
> No matter what, everytime my DC boots -> loads nic driver -> gets kernel via tftp
> -> loads kernel -> and then hangs at Root-NFS: No server available.
> We have about 12 other linux machines on this network, and I can mount
> /tftpboot/ from many others. /etc/exports reads as:
> /tftpboot/,no_root_squash) (DC)
> /tftpboot/,no_root_squash)
> And yes, I'm positive that the DC kernel which gets xferd over via tftp was
> compiled with the root-nfs, auto-configure, bootp, etc.. and all the other options
> which are necessary.
> The documentation says that in 2.2 kernels the default is /tftpboot/<domain>, so my
> tftpboot contains the root file system under the dir /tftpboot/
> I have even tried the mknbi -x -k zImage -o vmlinuz -d /tftpboot/ -i
>  -> same result No NFS server available.
  What doesn't your boottab line look like, and why don't you specify the
nfs root there?

> Some more info: I did compile the DC's kernel on a system which is SMP, although
> the DC is not. Problem? (it wouldn't compile unless I selected smp). The machine
> does have a hd which is detected when the DC's kernel loads. Problem? (however it
> is disabled in the BIOS).
  Um, that is /very/ odd. Why wouldn't it compile UP?  Finding a harddrive
isn't a problem.
> I'd really appreciate help with this, and if someone could stay with me through the
> configuration, and continue to act as a consultant, we'd be happy to pay well. We
> intend our DC's to be nodes on a fairly large JVM cluster. - Thanks Eric
> P.S. Where does NFS log things on the server side? I've been everywhere, and can't
> find it.
  Usually just the syslog, if at all.
> P.S.S Why occasionally upon booting do I get AX, CX, DX, repeatedly and repeatedly
> until eventually (although not always) something catches and the tftp get the
> kernel and loads it?
  That's odd.

  - Nick Lopez
This Mail was sent to netboot mailing list by:
Nicolas Lopez <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to