Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Regarding net boot... Please help

Hi ,

First of all, the hardware of the diskless workstation given to us is a
Intel P2 processor on a HP vectra motherboard and 3com NIC card whose model
number is 3c905B-TX. BIOS used is Amibios. 

The OS on the server is Red Hat Linux 7.01. 

They r connected using a ethernet cable.And my aim was to get it booted on

Now the procedure I adopted:

On the target side:
1: First of all, I set the first boot device in the BIOS as Network just to
test whether the NIC automatically broadcasts the its MAC address to the
nearest gateway, so that we can avoid any unneccessary floppy transactions.
It did not work.

ON the server side:
1.	First of all, the DHCP daemon was configured using dhcpcd.conf file
and daemon started.(This may be a point where I could have gone wrong..I
mean I cud have configured wrongly..>How shud one go about when only 2
machines are in the subnet and there are no other machines in the subnet)
This makes the server to listen for any DHCP requests over the ethernet.
2.	The TFTP server was already configured. So I did not have much to do
on that front.
3.	Third step was to get the network boot image on the floppy which
consisted of the intial start up code.
	For this, 2 s/w were readily available from the net for download
	One was etherboot: I downloaded this one and tried to compile it on
the server...I couldnot do it because it was not compilable by gcc 2.96...It
needed gcc 2.95 or 3x.

4.	Next logical step was to install a new compiler or go for another
s/w which is compilable by gcc 2.96. I took the second option....There was
another s/w called Netboot freely available on the internet...
5.	It got installed easily.
6.	now this netboot's features were that it can creat a network boot
image for a given NIC model and the OS we want to boot.
7.	This s/w intrinsically supported some NICS. Unfortunately, our NIC
was not in that list. In that case, I had to get the required NIC driver and
PROTOCOL.INI file required by it. I downloaded the 3c90b-TX driver
(3c90x2.exe from 3com website) and put it in the required directory. 
8.	then when I ran the s/w, it said "the DOS program reqires too much
memory and aborted the process"
9.	 when I checked with some NICs which are already available on the
list, it worked fine and it created a "image.flo" file which can be put on a
10.	But this floppy obviously dint boot the different NIC.
11.	I am struck at this point...Please help

	Sorry for the long mail
	Thank u 

Venkataprasad Chirreddy
Systems Engineer
Wipro Technologies 


For requests or suggestions regarding this mailing list archive please write to