Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 3c905c damaged / etherboot-4.4.x

Greg Beeley wrote:
> Ken Yap wrote:
> >
> > >So, I took another 3C905C NIC, put it in the same box:
> > >-bootrom PXE ok
> > >-tried etherboot
> > >---> bootrom PXE dead with the same msg
> The 3c905b part of the driver would set the media type internally to
> MII mode.  That was a workaround for a problem on the 3c905b that does
> not exist on the 3c905c.  I haven't looked at the patched 3c90x driver
> but it may be that it is trying to set MII mode for both 3c905b and
> 3c905c cards.
> To fix, try runningand setting the media type back to
> auto-negotiation 10/100.
> Let me know what you find.

ok, I've tried  3c90xcfg.exe, found everything normal
Then I've changed parameters ( Media etc .. ) booted again, 
run 3c90xcfg.exe again, auto-conf mode ( auto select etc ..)

Now, when I boot on PXE mode, 
I don't have any E61 Error message, just a new ( 4.11 version ? )
display about GUID followed by 00000 ...
Then I can see the DHCP request on my server but ... the client times

I've tried the TCP/IP mode with DHCP ... no problem, it gets the
response and then tftp a file

Another strange diag :
3c90xcfg.exe shows the ROM enabled but 3-link.exe shows it disabled ...

I didn't try etherboot floppy again

	Thanks a lot

Olivier PAGE                            Ingenieur Systeme (D) /
Tel : (33)                email :
Fax : (33)                ESM2:Ecole Sup. de Meca.
This Mail was sent to netboot mailing list by:
Olivier PAGE <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to