Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cnet pro 110b problem / 3com905c problem

I am pretty new to netboot, so if you think my problem is solved already
tell me.

I set up a 10 client diskless cluster with a SUSE 8.1 Server and a
near-selfmade Client-Linux based on Peanut-Linux.

Everything went fine as long as I didn't try to netboot.
(before I uses syslinux with a Kernel and a ramdisk)

I configured Netboot to run with my davicom 9002 Network card using
the davicom packet driver and everything worked fine.

Unfortunetly this Davicom Network card was my private unique one
and I had to set up the cluster with our existing 3com905c cards.

The netboot-part worked fine, but when the kernel tried to configure the
vortex-driver it hangs with a "to much work on Interrupt" error message.
Then I have to RESET the client!
I tried to manual override the interrupt from 5 to 11, no success.
I had the same problem using modules AND build in support for the vortex.

Using syslinux works fine with the 3com905.

It looks to me like a "bug" in the packet driver which blocks the card from
freeing and reusing the interrupt.

After diskussing the problem with a friend I decided not to bother the 3com
and to buy some cheap networkcards. I got cnet pro 110b cards with a davicom
(not 9002 as before, bummer!) chip and found out that I had to use the
Tulip - driver.

I got myself a cnet pro 110b packet driver and built the kernel with the
Now I got a strange behavior:
netboot starts and I got the dhcp-Message. But then the client waits between
5 an 30 seconds
before printing the "ok" and loading the tftp-image. While loading the
tftp-image the client
stops working for 5-30 seconds sometimes. After running the kernel
everything works fine.
The server reports only a single dhcp-request at that very moment the client
prints the "ok"

This is better then the 3com905 behavior but still not convincing.
I got both cards in stock now, and I don't want to by even more cards. So if
you can
help me on either of the problems I would be very glad.
By the way: I am still using the image.flo with a floppy if this is of any


This Mail was sent to netboot mailing list by:
"Roland Stiebel" <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to