Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strange NFS behaviour w/ diskless X terminal

Harald Milz wrote:
> Hi,
> I recycled an embedded board with a Cyrix GXm CPU for a diskless X
> terminal. Had to build an etherboot image for the RTL8139 card and patch it
> into the BIOS because the original BIOS only supports Netware boot. So
> what. 
> Now the /usr filesystem is mounted from my file server (mainly for the X
> server). When the start script (there is only one, for speed reasons) tries
> to mount /usr like
> mount -t nfs -o ro,rsize=8192,wsize=8192,hard,intr /usr
> it takes about 5 minutes until the mount command returns. In my server's
> syslog, /usr appears to have been mounted by the client immediately. 
> After a while, an error message comes up on the client
> portmap: server localhost not responding, timed out. 
> There is no portmap running on the client (why should it)...

Have you tried with portmap? Or use mount -o nolock.

> The kernel gets all its data from the DHCP server via autoconfig (even the
> root dir which is mounted via NFS too) 
> rsize, wsize aren't the problem. Same happens without these options. 
> What am I doing wrong? Ah yes, the NFSd is the userspace daemon. I also
> tried knfsd for NFS3 over TCP but that didn't work. Gave up very soon. 

Heinrich Rebehn

This Mail was sent to netboot mailing list by:
Heinrich Rebehn <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to