Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tftp hangs after 1037 blocks


Hello list!

I'm trying to boot an old desktop into Linux using dhcp/tftp. I have created
a bootdisk with netboot-0.9.8, but so far have not been able to boot via
network with images over 510kb.

The boot proces hangs at:
Options: Blocksize 512
Block 1037

The client is an old HP vectra (486sx33, 12Mb ram and ne2100 o/b). When I
use a smaller image (e.g. less than plm. 500k), the process does succeed,
however the kernel isn't ideal then (misses /proc now, for example).

I also have tried to boot the same image directly from floppy, and have
succeeded. So it's not the image itself that fails.

Do you have any suggestions as to where I should look for a solution? I
haven't found anything in the archives. Can this have anything to do with a
memory boundary (e.g. 640 kb)? I don't have another machine available to
play with, so I can't test on another system.

Maybe I should add that I have tried multiple images of varying sizes -
anything above 510kb hangs at block 1037, anything below succeeds.

One additional question:
Is it correct that images built with make bzImage will fail anyhow? Or am I
missing something here?

I'd be grateful for any help

Arno Schuring

For requests or suggestions regarding this mailing list archive please write to