Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: root fs

Bill wrote:

>Hello List,
>I am trying to use netboot 0.8.0 and 0.9.1. I find it easier to use
>0.8 for the moment.
>I am a bit slow learning. Have been reading documentation on netboot
>and NFS, but somehow still cannot figure out the problem below. Can
>someone give simple steps to guide me?
>I have compiled kernel to redhat 6.2 server. Installed dhcpd and nfsd.
>I have tagged kernel with mknbi-linux. I have prepared bootrom floppy.
>I have the following files.
>I tried to boot from diskless workstation with floppy, it goes ok
>until it stops at VFS : no root file system....
You need an rp:hostname:/path/to/nfs/export tag in dhcpd.conf.

You need to compile in the NFS root option into the kernel.  Strangely, 
you need to enable bootp IP configuration in the kernel for the nfs root 
option to be available to enable.

You also need to set 'no_root_squash' on the nfs filesystem to be exported.

Hope that that helps.  And that you haven't already gone over to the 
dark side (LTSP ;-)


>I suspect problem with export of NFS or root FS.
>Any past mailing list which covers the same subject with answers that
>are helpful to me? Any tips on where to read up on setup step by step on bootp, exportfs
>and root fs?
>I use bootp and dhcpd to start remote workstation.
>After spending 4 weeks on this, I still get nowhere. Hope some help
>can get me going here. Thanks in advance to all the experts out there.
>Cheers to OPEN SOURCE and GPL/GNU.

Complexity Happens

This Mail was sent to netboot mailing list by:
Crispin Murphy <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to