Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

booting DOS using mknbi-dos from netboot 0.9e


I have had problems booting MS-DOS 6.0.  I got semi-random systemcrashes
(hangs) when I made boot images using dosfiles from a directory.  I also
tried with an image of the whole disk (dd ...) same result.
I am trying to make a DOSboot using MSClient software to connect to my Samba
server.  I am using netboot 0.9e for bootROM as wel as boot images.
The netcard uses an RTL8139 chip.
I included the option /testmem:off at the himem.sys commandline, but it
doesn't know this parameter (v 3.09).

If I use the -k option with mknbi-dos then I get two different responses:

-k all, -k undi  --> System boots fine, except netcarddriver won't load.

-k none   --> System hangs immediately after "Starting MS-DOS...". I do not
even get output from himem.sys,...
When changing the imagesize to 2880, the boot hangs at a later time.

Linux and menu images boot fine.

I tried the demo menu.mgl file supplied, but I don't get any colors?
Somebody knows a solution?

If you want more detailed info, please ask.

Hope somebody knows how to fix this.

Greetz,   Jan

This Mail was sent to netboot mailing list by:
"Freegates" <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to