Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RTL 8139 Problems - seems to be an old one .....

Christoph Plattner wrote:
> I tried to use the OvisLink card with the Realtek 8139 the frist
> time with 'etherboot'. And it does not work. If I try to boot Linux,
> it first interrupt the download with an error 'BOOTP block to big',
> or something like that, then it continues loading, but hangs then
> completely.

Can you quote the precise error message?  I couldn't find an error
message in the BOOTP code that looks sufficiently similar to the one
above.  In fact there isn't much that can fail.

Because this seems to be a weird problem, using a network sniffer might
give a hint where the problem really is.

> If I try to boot the 'nbgrub' image, than the machine reboots after
> loading the image.

Did this image work using some other card?  Could be a broken image -
is it really a NBI image????

> I read some mails in the mailing list archive about this nic.
> Some problems concerning the PS/2 mouse I found. The board has a
> PS/2 mouse interface, but no PS/2 mouse were connencted (boards
> I tried: ASUS PVI-486SP3 with DX/4-100 and a Gigabyte ATE/P with a
> Pentium 100MHz).

The mouse interface should be irrelevant for etherboot working or not.
It would surprise me if this is not the case.

> In an other mail I read, that the rtl8139.tmp must be < 32KB. Why ?
> In my case it has nearly 61-62KB and no special option is used.
> The only thing I try is the serial console, but also without, I have
> the same effect. Also the -DNO_DHCP.... has not improved the thing.

Did you misunderstand the section in the docs concering the size of the
ROM image or is it misleasding?  The correct way to get the size of an
image is the "size" tool shipped with the binutils.  The number listed
in the 'dec' column must be below 32K (minus some space for the BIOS -
usually 1-2K - and the stack - usually 1-2K).  My rtl8139.tmp uses 88798
bytes on the disc, but only contains a 24201 byte ROM image.  The rest is
symbol tables, debugging info and so on.  This doesn't get included in the
ROM image.  But as the ROMs are usually compressed and the size AFTER
decompression must be below 32K there is no easy way to guess the size
from the compressed ROM file.

Anyway - if the ROM works it should print a line "ROM segment xxxx length
yyyy reloc zzzz" - if the length printed is above 16K and below 32K
everything should be fine.

> The ROM image has 16KB and I used some different EPROM chips:
> AMD, intel, SGS Thomson, NMC, etc... (27c128 and 27c256)
> Some of them fail in the Pentium board, all of them work in the
> 486 board, but in all cases I have the effects described above.

This seems to indicate that 486 chipsets tend to use slower accesses
to the ROM image, making slower ROMs work.  It might help if you have a
closer look at the types and access speeds of the ROMs failing to work
in Pentium machines - especially the number after the dash is interesting.
Someone suggested that a hardware compatibility database should be collected
trough a web interface and this

> When I boot GRUB from disk, the etherboot driver included in the
> GRUB package work well for the RTL8139 (not for the RTL8029, as
> described in my last bug report concerningthe probing).

How old is the card?  What chip revision is on the card (most likely an
original RTL8139 or at most a RTL8139A)?
This Mail was sent to netboot mailing list by:
Klaus Espenlaub <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to