Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RTL 8139 Problems - seems to be an old one .....

I tried to use the OvisLink card with the Realtek 8139 the frist
time with 'etherboot'. And it does not work. If I try to boot Linux,
it first interrupt the download with an error 'BOOTP block to big',
or something like that, then it continues loading, but hangs then 
If I try to boot the 'nbgrub' image, than the machine reboots after
loading the image.

I read some mails in the mailing list archive about this nic.
Some problems concerning the PS/2 mouse I found. The board has a 
PS/2 mouse interface, but no PS/2 mouse were connencted (boards
I tried: ASUS PVI-486SP3 with DX/4-100 and a Gigabyte ATE/P with a
Pentium 100MHz).

In an other mail I read, that the rtl8139.tmp must be < 32KB. Why ?
In my case it has nearly 61-62KB and no special option is used.
The only thing I try is the serial console, but also without, I have
the same effect. Also the -DNO_DHCP.... has not improved the thing.

The ROM image has 16KB and I used some different EPROM chips:
AMD, intel, SGS Thomson, NMC, etc... (27c128 and 27c256)
Some of them fail in the Pentium board, all of them work in the
486 board, but in all cases I have the effects described above.

When I boot GRUB from disk, the etherboot driver included in the
GRUB package work well for the RTL8139 (not for the RTL8029, as
described in my last bug report concerningthe probing).

I hope anybody can help me .......

Thanks, and greetings

	Christoph Plattner

This Mail was sent to netboot mailing list by:
Christoph Plattner <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to