Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Booting Diskless hanging at the tftp step

On 1/4/2000 6:16 PM Matthias Schniedermeyer wrote:
>I build a diskless Computer (With etherboot 4.2.13, Linux 2.2.12 base was
>a SuSe 6.2) and got it to work with bootp. Everythink worked and i dicided
>to burn the EPROM. Now happend a little accident and the EPROM was burned
>with DHCP and not bootp. So i went and fetched isc-dhcp 2.0 and tried my
>Server: Intel EtherExpress Pro 10/100
>Client: Realtek 8139 10/100
>Connected via a 100 MBit Hub
>Burned is the rtl8139.lzrom of a freshly untarred etherboot-4.2.13 with NO
>changes in the Config.

You may have two problems to solve.  First, I recommend that you patch 
the file src/rtl8139.c with the following 2 line patch:

    <       unsigned char tx_bufs[TX_BUF_SIZE * NUM_TX_DESC + 4];
    >       unsigned char tx_bufs[TX_BUF_SIZE + 4];
    <               tx_buf[i] = my.tx_bufs + i*TX_BUF_SIZE;
    >               tx_buf[i] = my.tx_bufs;

[ on line 120 remove "* NUM_TX_DESC " and 
  on line 302 remove " + i*TX_BUF_SIZE" ]

Then cd to the src-32 directory and do a "make" as usual.

This should give you a memory image that is more likely to work in the 
limited memory available in the pre-boot environment.  Someone else 
reported a tftp problem recently that was solved by the above patch.

After you apply the patch, make a floppy with "make rtl8139.fd0" or 
however you usually do it.

The DHCP code seems to use more memory than the BOOTP code, so even 
though you might be able to use BOOTP with your rtl8139, adding DHCP code 
may make the code too big without the patch. The patch saves memory 
(stack space) during execution, and may solve your problem.

There could also be problems with your DHCP configuration on your server. 
If you send it to the list, we can check it out for you.

>Is there any hope that i can get it to work with that EPROM? Or do i have
>to burn another one.

You will probably need to burn another EPROM (or erase and reburn the one 
you currently have).  I suggest you wait until floppy booting is working 
for you before making another EPROM.

Please report your progress (positive or negative) so that we know if 
this patch is effective.  Also, could you do:

   cd src-32
   size rtl8139.tmp

and report the result?  Danke.



   Name: Martin D. Connor
US Mail: Entity Cyber, Inc.; P.O. Box 391827; Cambridge, MA 02139; USA
  Voice: (617) 491-6935, Fax: (617) 491-7046 

This Mail was sent to netboot mailing list by:
Marty Connor <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to