Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PS/2 mice causing RTL8139+Asus mes/n+etherboot 4.2 to not boot

>We've been going mad trying to get our new Asus MES-N + etherboot-4.2 prom 
>diskless linux boxes to boot.
>If we insert a ps/2 mouse it won't boot, the BIOS claims the ethernet
>card is on the irq we select (i.e. 5,7,9,10 or similiar), but it seems
>to be conflicting with the mouse (usually at 12).  We have tried a significan
>number of changes to try to get this to work.
>Any ideas if it's a hardware problem? Bios? Etherboot config?
>Or similiar?

Yes, someone else on the list had this problem and there was no solution
found so he went with serial mice. On the other hand some people did have
success with this rtl8139 and PS/2 mice. It shouldn't be an IRQ problem
because Etherboot doesn't use interrupts. It seems to happen to several
motherboards but not other NICs so it's probably a driver problem. The
only guess I had was that perhaps the RTL8139 driver had too large a
footprint (32kB max) and was somehow scribbling over the piece of memory
the BIOS uses at the top of 640KB. I suggested rebuilding rtl8139.{lz,}rom
with all extra features removed. No reply on whether that worked.
This Mail was sent to netboot mailing list by:
Ken Yap <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to