Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Still RTL8139 Problems (combination with ps2 mouses)

On Wed, 8 Dec 1999, Ken Yap wrote:

> >In all cases I use a newer AWARD bios (4.51), there is no chance to
> >disable the mouse...
> How about if you disconnect the mouse while booting and connect it only
> after booting? This is not practical for daily use of course, it's just
> to prove a theory.

Hm, I plug in the mouse, short after the tftp process is started, the
kernel detects it, but it seems not to work then, tried multiple times
If I plug in the mouse while BIOS bootup and remove it before dhcp starts,
the I have the problem described before (tftp never starts to transfer
> >>This experiment to see if the BIOS is doing something special in the
> >>presence of a mouse. I suspect it's loading some code or data at the
> >>top of 640k, which would upset Etherboot's stack.
> >
> >I'm still a little confused, how the improvement came from out of version
> >4.2.9 to 4.2.10 and why it isn't able to tftp ...
> I think it was random. It could have just as easily become worse if the
> wrong part of the stack was destroyed.
> What about other models of NICs, do they have the same problem? If they
> do then it's a strong possibility that the BIOS is using some memory
> just under 640k.

Hm, I tried a NE2000-PCI clone (rtl8029) with 4.2.9 etherboot, no problem
with ps2 mouse ... tftp starts and systems works fine. Other NICs were not
at hand.

Thank you!


This Mail was sent to netboot mailing list by:
Dirk von Suchodoletz <>
To get help about this list, send a mail with 'help' as the only string in
it's body to If you have problems with this list,
send a mail to

For requests or suggestions regarding this mailing list archive please write to