Netboot Mailing List (by thread)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: etherboot - "Wrong ramdisk image"





----- Original Message ----- 
From: "Geert Stappers" <Geert.Stappers@xs4all.nl>
To: <netboot@baghira.han.de>
Sent: Wednesday, July 16, 2003 3:32 PM
Subject: Re: etherboot - "Wrong ramdisk image"



On Wed, Jul 16, 2003 at 12:49:05PM +0300, Ziver Alen MALHASO?LU @ ERSE wrote:
> 
>     Hello,
> 
>     I am tring to network boot my thin clients using etherboot. But when it
> gets the image from the dhcp server it complains "Wrong ramdisk image"
> 
>     I tried to create the image exactliy obeying the instructions at
> http://etherboot.sourceforge.net/doc/html/mknbi.html#mknbidos
> but when i gave the command "mknbý*dos /tmp/floppyimage.320 -o dos.nb" it
> said "mknbi-dos: DOS image file has invalid number of sectors"
> 
>     Do you know how to solve this problem?

 -    Tell us more about /tmp/floppyimage.320
 -   ( what is it, how did you make it, where did you get it )
 -
 -   And don't forget to tell how you solved 
 -  the problems that you reported.


    OK. First thank you for your interest because i have been suffering here, because of this issue for 7 days.In addition i have to solve this problem because it is the basis of a project.

    My diskless computer is a 80386 with a 640 KB conventional memory, 128 KB extended memory. My linux server is powerful enough to administer all the diskless clients' queries.

    I created an application that runs in DOS environment, i tested it on Caldera's DR-DOS, but it will probably work on MS-DOS, FreeDOS too. 

    I will tell you the whole story.
1)    i decided to give a chance to etherboot
2)   then  i tried netboot to accomplish network boot. But it failed (wait i will explain why it had failed)

1st story)    Etherboot
    I used     the document which is located at: http://etherboot.sourceforge.net/doc/html/userman.html
I did not compile any ROM images. My diskless has a ethernet card which contains UMC chipset, the identifier of the chip is UM9008F (9639-AT, M61310). I have found my NIC's chipset at http://www.etherboot.org/db/nics.php?show=tech_data&chip_manufacturer=UMC and downloaded the stable ROM for "UM 9003AF" from http://rom-o-matic.net/latest-production-release/?nic=ne (I also tried to use UM 9001l's ROM but it failed to recognize the ethernet adapter.)
    I configured my DHCP server with the following dhcpd.conf file:
</etc/dhcpg.conf>
default-lease-time 86400;
max-lease-time 86400;
option subnet-mask 255.255.255.0;
option broadcast-address 10.255.255.255;
option routers 10.10.10.1;
option domain-name-servers 10.10.10.1;
option domain-name "erse.com.tr";
ddns-update-style ad-hoc;
authoritative;
subnet 10.10.10.0 netmask 255.255.255.0 {
    range 10.10.10.200 10.10.10.250;
}
host DumbClient1 {
    hardware ethernet 00:80:AD:B2:48:99;
    fixed-address 10.10.10.210;
    filename "/tftpboot/drdos6.nb";
}
<//etc/dhcpg.conf>

    When i RAWRITE the downloaded ROM image to a diskette and boot the client with that diskette everything goes OK; client's adapter are detected, and DHCP server is found. Client gets it IP from the DHCP server. But when it tries to load the boot image from the DHCP server, problems occur at that moment. Such as:

    I prepared a few boot images in order to test my diskless client if it will bott or not. There are 3 kinds of tagged boot images: 
1.1)    Images that contains MS-DOS files    
1.2)    Images that contains DR-DOS files
1.3)    Images that contains FreeDOS files
    I will explain what happend when i tried to boot from each image.

1.1) I have a MS-DOS 5.0 boot diskette taht contains: command.com, fdisk.exe, format.com, io.sys, msdos.sys, and sys.com. I got it from: http://www.oldstuff.myagora.net/powerload/
    I did "mknbi-dos msd622bd.img  msd622.nb" and then configured the dhcpd.conf file according to the file's path. Then i booted my diskless. It gave the message:
"loading 10.10.10.175:/tftpboot/msd622bd.img ....(NBI).......
......................done"
    Thus it loads the image but it does not start the operating system. I couldn't manage to boot the operating system after this image load. Why it does not start booting?
    I also tried the MS-DOS 5.0 boot disk and the result is the same. It loads but doesn't boot!

1.2)    Since http://etherboot.sourceforge.net/doc/html/userman-6.html says dr-dos 7,02 is booted over the network succesfully i downloaded the insatallition image of the Dr-DOS 7,02 and tried to boot again.
    Diskless gave the message:
"Loading 10.10.10.175:/tftpboot/drdos72d1.nb...(NBI)..
.............done
DOS Net Boot Image Loader Version 0.9.8 (netboot)
Coypright (c) 1995-2003 G. Kuhlmann

Starting Caldera DR-DOS...

"
    After displaying above messages diskless client halts and does not boot any further.

1.13) I followed the instructions about FreeDOS. 
"It has been tested with 2012 but nothing older"  but i had i use an older version. I tried FreeDOS (may be downloaded from http://sourceforge.net/projects/freedos/) kernel 2030.
    I extracted kernelįsys from the image and made the network boot image according to http://www.codeblast.com/~gert/misc/freedos.html    The diskless booted! That was wonderful, most of the  messages were the same as booting from the floppy, such as*:
"
FreeDOS kernes version 1.1.30 (Build 2030)

(C) Copyright ....
....
...
 - InitDiskno hard disks detected

System shutdown complete
Reboot now
"
    CONFIG.SYS and autoexec.bat are two zero lenghted files.
*    The missing message was:
"FreeCom version 0.82 pl 2 XMS_Swap [Apr 28 2003 17:47:52]"

    I think the system halt because of a problem related with FreeCom. because when i use floppy it loads FreeCom but on network i can not!

2)    netboot problems

    I tried to netboot my FreeDOS image with netboot package but it displayed the following message at client:
--
DOS Net Boot Image Loader Version 0.9.8 (netboot)
Copyright ...

Wrong ramdisk image

Network boot failed.
--

    2.2) DR-DOS
    halts after displaying "Starting Caldera DR-DOS" message


2.3)    MSDOS

    MSDOS fails with the message
"
Wrong ramdisk image

Network boot failed
"
    Somebody help me! :-)

    This is a really important problem for me, please show a solution.

Regards,
Ziver Alen MALHASOGLU


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.501 / Virus Database: 299 - Release Date: 14.07.2003
===========================================================================
This Mail was sent to netboot mailing list by:
"Ziver Alen MALHASOGLU @ ERSE" <ziver@erse.com.tr>
To get help about this list, send a mail with 'help' as the only string in
it's body to majordomo@baghira.han.de. If you have problems with this list,
send a mail to netboot-owner@baghira.han.de.



For requests or suggestions regarding this mailing list archive please write to netboot@gkminix.han.de.